> ## Documentation Index
> Fetch the complete documentation index at: https://moengage.com/docs/llms.txt
> Use this file to discover all available pages before exploring further.

# Why Does a Test In-App Fail to Render on Devices (In-App V2)?

> Diagnose why test in-app campaigns fail to render on devices in MoEngage In-App V2, including custom redirection and activity name issues.

## Problem

The testing of an In-app campaign fails in the last step to check how the In-app looks and how is the response.

## Cause

This issue can occur due to one of the following reasons:

* **Custom redirection**: When you send an In-app test campaign, a splash screen or blank activity will open, and then it will redirect to the main activity screen where it will show the In-app message. But due to this issue, the call made to the server to fetch the In-app message is dropping and hence users cannot see the campaign.
* **Activity name is missing**: When you are testing the In-app message, it selects a random activity from the backend to show on the screen but if the activity is missing from there, MoEngage will not show the In-app message.
* **Key-Value pair**: It is not similar to the one seen in Campaign Creation. It is picked up from the backend, sometimes while testing the In-app message. If the key-value pair is missing then also the in-app message will fail to show.
* **Activity instance is null**: This means that if there is no screen, then also MoEngage will fail to show the In-app message.

## Solution

You can create a test campaign targeting yourself or a group of test users.
